Error Installing Nodes

Hey guys, completely new to opennebula and linux. First time installs on both so I probably messed something up along the way but I am having trouble with the installation of nodes onto my server. I am running a single server setup with Ubuntu 14.04 LTS. I am following this quick start:

Although it is for the KVM hypervisors I am using vmware. I believe I read that you could follow that guide if you are using vmware as well.

Anyway I installed sunstone and have gotten halfway through the write up. When I get to section 2.2 “Installation in the Nodes” I get this error after running “apt-get install opennebula-node nfs-common bridge-utils”

"Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Anyone know whats happening here? I dont know the first thing about linux and have no idea how to trouble shoot this. I’ve tried googling some things but they all lead to PHP. Any help would be greatly appreciated. I attached a screen shot as well.

Thanks guys!


Try this -

sudo dpkg --configure -a
sudo apt-get install -f

If the above do not work then try the below command.

sudo apt-get remove --purge getdeb-repository

Kiran Ranjane

1 Like

Thank you, this worked!