Upgrading from 4.6.1 to 4.12 - Issue with packages

Hello Guys,

I updated my repo info on Ubuntu 14.04 to get access to ONE 4.12.

Unfortunately when I try to apt-get install opennebula, I get the following unmet dependencies :

$ sudo apt-get -s install opennebula opennebula-sunstone
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
opennebula : Depends: libc6 (>= 2.17) but 2.15-0ubuntu10.12 is to be installed
Depends: libxmlrpc-c++8 but it is not installable
E: Unable to correct problems, you have held broken packages.

Could you help ?
Thanks in advance

I finally succeeded by manually installing the dependencies… Soooo sad.

Amazing new Sunstone graphs :smile:

But, I can’t connect on the VNC proxy to a VM.
It’s just hanging on VNC HANDSHAKE
I updated the configuration of sunnstone for VNC…

Any help ?

Thanks in advance
CyD

hi Cyrille,

could you post a relevant part of /var/log/one/novnc.log ?
Also, some details about the changes you made to sunstone are helpful.
(like a copy of the UI_settings part of your sunstone config file)
With the info you supplied so far it’s kinda hard to help :slight_smile:

cheers, Roland

Hello,

Here novnc.log: connection refused :
10.1.5.6 - - [20/Jul/2015 23:54:56] 10.1.5.6: Version hybi-13, base64: 'False’
10.1.5.6 - - [20/Jul/2015 23:55:01] 10.1.5.6: Path: '/?token=htjjs8vog8jelqzm6pcs’
10.1.5.6 - - [20/Jul/2015 23:55:06] connecting to: orthanc.local:6222
handler exception: [Errno 111] Connection refused

And the UI_settings part :
################################################################################

# UI Settings
################################################################################
# :vnc_proxy_
#   port:           port where the vnc proxy will listen
#   support_wss:    no | yes | only. For yes and only, provide path to
#                   cert and key. "yes" means both ws and wss connections will be
#                   supported.
#   vnc_proxy_cert: Certificate to encrypt wss connections.
#   vnc_proxy_key:  Key for wss connections. Only necessary if not included in cert.
#   vnc_proxy_ipv6: Enable ipv6 support for novnc-server
:vnc_proxy_port: 29876
:vnc_proxy_path: /usr/share/opennebula/websockify/websocketproxy.py
:vnc_proxy_support_wss: no
:vnc_proxy_cert:
:vnc_proxy_key:
:vnc_proxy_ipv6: false


# Default language setting
:lang: en_US

# Default table order
:table_order: desc

I reused the exact same config as the previous version.
Thanks
Cyrille

hi Cyrille,

my current 4.12 config contains:

:vnc_proxy_port: 29876
:vnc_proxy_support_wss: only
:vnc_proxy_cert: /etc/one/ssl/somesite-certchain.pem
:vnc_proxy_key: /etc/one/ssl/somesite-key.pem
:vnc_proxy_ipv6: false

I used a key for the socket to protect the VNC traffic, so thats different and I set the wss support to only. In you log, I see “orthanc.local:6222” - if you are using a single host, that will resolve ok, but if you are using a cluster of multiple servers, that address might not work everywhere.
It will work ok if your sunstone is on the same server as the VM, but if a VM is on a different host and sunstone is on another computer, it wont resolve properly.

check this trying to reach the address from the computer commandline that’s running the VM using telnet for example and see if something is listening on port 6222.

Another cause can be that the VM is deployed with a VNC listen address configured, instead you should use “0.0.0.0” as the VNC listen IP in your templates. (see: http://dev.opennebula.org/issues/2254 for a similar example)

hope this helps!