How set vCPU quota

I have problem with CPU quotas. In quotas no vCPU, only CPU.
I create 1VM with 1 CPU and 16 vCPU. Starting test and see 1VM get 100% HOST CPU utilization. Its normal? Or I don’t understand how it works?

P.S. Sorry for my English.

Hello, any one have answer on this questions ? it’s very important…

b/c for example I provide one cpu to user, but when he creates VM - he can use unlimited vCPU and it will kill host node
I think we need restrict vCPU per user and not per Template (VM)


I tested it myself. i can, as user, to create a vm with 100 VCPU and USE it ALL!!! this must be fixed asap!

The vCPU is a VM configuration parameter, it just tell de VM de number of virtual cores. The amount of CPU that the VM will take from the hosts is specify with the CPU parameter and it is not a fixed amount is proportional. So if you set up a VM with CPU value of 1 give it N VCPUs and start to test it with only that VM running it will take all the CPU.