miniONE 5.12 - attach public IP subnet to VMs

Hi there,

I’m new to the forum and would like to introduce myself in a short way: I’m a IT engineer from the north of Germany and I don’t have much experience with OpenNebula.

My project: For development purposes I’m running a Mini One 5.12 on a bare metal cloud server and on top of CentOS 7.9. After testing around with different OS I decided to use CentOS because in my opinion OpenNebula “felt” a bit better than on Ubuntus in terms of speed and reliability. However - everything is working perfect and what I would now like to do, is to connect my VMs to the world. To do this, I ordered a /28 subnet of public IPs for my machine and tried to build (via GUI) a new bridge to attach them to the VMs. I’ve tried this with a bridge w/o sg and a bridge with sg - nothing is currently working. When I’m creating a bridge with sg, there is no bridge visible on CentOs, building a bridge w/o sg, it is visible on OS. Additionally, a new VM connected to the bridge with sg cannot be created. VMs running on bridge w/o sg are not reachable.

Maybe someone can help me how to do it the right way.

Thank & regards