OpenNebula integration with NSX-v


I’m trying to integrate my vmware environment with opennebula, I added my host clusters and import previously created VMs and Networks, In the virtual network creation tab when I choose the type as NSX, next step it asks me to selet host and transport zone, but transport zone dropdone menue is empty,
I checked the NSX tab under hosts clusters which asked for NSX_USER and Password, I tried with both vcenter SSO administrator and NSX admin user, both are validated successfully but nothing is changed, still no transport zone is shown in NSX tab or in network creation section.

Below is my environment setup info,
opennebula istalled on centos 7 and 8
opennebula version: OpenNebula (54eb4054)
vcenter server: 6.7
NSX-V: OpenNebula (54eb4054)

ca anyone help me? it’s very urgent, is there any compatibility issue ?
thanks in advance


Is the vCenter cluster correctly monitored? Check that the state is ON and that no error messages are shown in /var/log/one/oned.log

Thanks for your response, I removed and re-add vcenter server again and monitored the logs in the path you mentioned plus monitor.log and vcenter-monitor.log,
No error was found, everything was successful, but still transport zone section is not shown, and when i want to add new virtual network transport zone dropbox menue is empty.

can you provide these two log files, as well as the output of onehost show -x , where hid is the id of the OpenNebula host representing the vCenter cluster where the NSX manager is configured.

nebula-logs.rar (737.2 KB)

attachment u can find requested logs. As I understood, during monitor process it gets NSX Transport Zones by calling GET /api/2.0/vdn/scopes, but maybe something gets wrong in this step

Hello again,

The issue fixed by running this command :
onehost forceupdate -c

I’m not aware of this command background processes, but the main point is that we need this process to be done automatically by entering NSX user-pass in sunstone portal (as described in opennebula documents)

onehost forceupdate forces a monitoring cycle over a particular host. If you can reproduce it again, please up the debug level in vcenterrc file and send us the logs again (no useful information so far)

BTW, you should check your DB performance:

Thu Sep 10 13:04:59 2020 [Z0][SQL][W]: Slow query (10.56s) detected