Problem in installation of opennebula


We have been trying to install your product opennebula but we are unable to do so properly. Even though we have completed every step, we are unable to run the command - one start. It gives us an error that file mm_shed. could not be found in the directory /usr/bin but the file is available. The screenshot has been attached for your assistance.
Please help us out on how to rectify the problem.

Could you start the service as root user as below:

root@server# service opennebula start
root@server# service opennebula-sunstone start

No, I couldn’t. This is the error that I am getting.

In our installation on Centos 7:

# ls -l /usr/bin/mm_* -rwxr-xr-x 1 root root 837176 Jun 15 13:51 /usr/bin/mm_sched
Are sure you followed instructions from guide? There is another rights in your setup.

Actually, I am installing it on Ubuntu 15.04. Secondly, this command just shows presence of the file mm_sched., even though it says in the previous error that no such file/directory was found

On Ubuntu 14.04 i have same result.
rwxr-xr-x 1 root root

Oh, you have DOT after mm_sched in filename

I have changed the permissions according to what you had but it still gives the same error. Even the error has same file name as present file (that is, both contain dot)

Dot in error is not part of filename. Remove dot.

This is the error I get when I renamed mm_sched. to mm_sched

As i said. You had wrong permissions and filename. Maybe you used wrong guide?

I don’t know, maybe I did, but I think I probably followed all steps correctly from the correct guide.
What do I do now after I get this error.

Reinstall using correct guide ? Or wait for answer from developers.

Will this guide work for ubuntu 15.04 too?

Not sure. At least you should use deb stable opennebula instead of 14.04.


Your screenshot shows a copyright from 2013… The last stable version, 5.0, was released this week.

Ubuntu 15.04 is not officially supported, although it might work without issues. The certified Ubuntus are 14.04 and 16.04. See the platform notes for more information.