VMRC console doesnt work

Hi,

Im using vOneCloud 6 with vCenter7.
There is a problem when I want to open a console with users other than “oneadmin”. It works without problem for oneadmin and for any VMs. But for other users not. I always see this error in oned.log:

   UID:4 one.host.info result FAILURE [one.host.info] User [4] : Not authorized to perform USE HOST [3].

Or
UID:3 one.host.info result FAILURE [one.host.info] User [3] : Not authorized to perform USE HOST [3].

There a message in Sunstone console:

 It appears there was a server exception. Please check server's log.

and I can see in Troubleshooter 500 error for startvmrc.

Any Idea?

This is indeed a bug. This will be solved in future releases.

As a workaround (not ideal) please give users USE permissions over HOSTS.

Thanks for reporting this!

Thank you for your reply.
it doesn’t work. I checked all boxes in ACL for a group about everything but in the end I got the error again.
I saw two messages in vCenter. first one appeared when I used oneadmin:

Date Time:
04/27/2021, 3:20:07 PM
Type:
Information
User:
VSPHERE.LOCAL\vonecloud
Description:
04/27/2021, 3:20:07 PM User VSPHERE.LOCAL\vonecloud@10.x.x.x logged in as Ruby
Related events:
There are no related events.

The second is when I used other users:

Date Time:
04/27/2021, 3:23:11 PM
Type:
Error
User:
vsphere.local\vonecloud
Description:
04/27/2021, 3:23:11 PM Cannot login vsphere.local\vonecloud@10.x.x.x
Event Type Description:
A user attempted to log in with an unknown or invalid username
Possible Causes:

The username is unknown to the system Action: If you are using Active Directory, check the health of the domain controller
The user provided an invalid password Action: Supply the correct password

Related events:
There are no related events.

How its possible for same username?

OpenNebula always uses the same username (the one defined in the OpenNebula host representing the vCenter cluster) to communicate with vCenter, regardless of the OpenNebula user initiating the action.

Regarding the permissions error, could you temporarily add the user to the oneadmin group and check again?

I’ve already tried it. it works fine. But it’s not the right solution.

Please double check your ACL configuration, user needs to have USE permissions over the host. Alternatively, upgrade to 6.0.0.1 where the bug is fixed.

I tried new version and it works. thanks!

I just want to mention that the problem still arises when using cloud view for users and admins.