VNC on imported vCenter VMs

Hi there. I think this should be a simple one - im sure i just missed something along the way.

SO i deployed the 2.2 appliance and have imported my vcenter and a selection of machines.

I made the remotedisplay.vnc.port, ip, and enabled edits to a test VM and enabled the gdb server on all of the hosts.

I tested the VNC connection using a VNC client addressing the host the test vm was running on and it works

On the VM detail page in Nebual the console link is still disabled and if i hover over it it says “You have to boot the virtual machine first”

I have set those settings on a VM before importing as well and no change in dashboard button state.

Any advice?

For vOneCloud related topics there’s another forum. You can submit your questions there.

In any case in OpenNebula, if the VNC icon is disabled while the VM is in the running state it would be caused by the absence of a GRAPHICS/TYPE attribute element set to VNC. You could check if the VM has that attribute in the template tab for the VM (using the admin vcenter view) or running a onevm show VMID -x CLI command (replacing VMID with the ID of the VM).

Let’s see if that GRAPHICS section is there and then let’s see why it’s not there :wink: because if you have a VM running in vcenter, you poweroff the VM, add the remotedisplay.* and then import a wild tab that GRAPHICS section should be there. But it would be better to use the vonecloud forum instead.