Adding a Host - error - Debian 9.7

I’m trying OpenNebula on Debian 9.7 hosts.

For FrontEnd, I followed:

For KVM host, I followed:
for step 8, I got error message at SunStone dashboard.

oned.log file at

Can anybody spot the problem?

Hello @sevilla.larry

Could you send me the output of ls -la /var/lib/one/remotes?

Execute onehost sync --force too.

Mon Feb 18 15:19:54 2019 [Z0][InM][I]: scp: error: unexpected filename: .

i got the very same issue on ubuntu 18.04 with 5.7.90. Impossible to add host.

i made it work here with

seems that changing

by adding before SCP


solve it

Hey @ghis_le_curieux,

I have exactly this same error while trying to add a host to my new Opennebula installation on Ubuntu 16.04.5 installation.

I tried adding the lines you suggested before the SCP entry:

# Copy files to the remote host
log "Cloning $SRC in $DST_PATH"
exec_and_log "$SCP -r $SRC $DST" "Error copying $SRC to $DST"

But got the same error:

Mon Feb 18 14:48:27 2019 [Z0][InM][I]: Command execution failed (exit code: 1): scp -r /var/lib/one/remotes/.
Mon Feb 18 14:48:27 2019 [Z0][InM][I]: scp: error: unexpected filename: .

I have confirmed that ssh works without a password and I can’t find any mention of “Monitoring host” in any files under /var/lib/one/remotes, so am at a loss as to how to resolve this.

(Edited because the $ character didn’t appear originally,which made the code incorrect)

Thx for the reply.

Tried your changes, but still Error.

Yes, I have the same error.

my change for each variable id done just before the scp commands


log “Cloning $SRC in $DST_PATH”
exec_and_log “$SCP -r $SRC $DST” “Error copying $SRC to $DST”

exec_and_log "$SCP -4r $SRC_HOST:${SRC_PATH_SNAP} $DST_HOST:${DST_PATH_SNAP}" \
    "Error copying $SRC to $DST"

it worked for me for lxd host, i dont know if kvm host differ in the scripts used, perhaps there is need to have the same change in a lot of places. The best would be for opennebulla to NOT add this ‘/.’ at the path end :slight_smile:


Still the same error.

I used KVM.

Hello guys,

The bug has been solved in master, so in the release 5.8 it will be available.

Here you have the 2 commits that fix it:

Many thanks for the update info Alejandro. I am restricted by what I can installed, so I can’t install all the compilers and dev libraries needed by the current 5.8 dev release.

Any idea when this will be released in a production bundle?

Hello @MartinW

It will be released next week.

Thank you for the info…