seems to return too little

<?xml version="1.0" encoding="UTF-8"?>

I’m getting only this info, no usage or similar.
This is on 4.14.2-2 and I’m trying to test the oneinsight addon.

onehost monitor works OK, so I’m not sure what’s going on.

The curl they do looks sane
curl -H "Content-Type: text/xml" -X POST \ -d "<?xml version='1.0'?> <methodCall> <methodName></methodName> <params> <param> <value><string>$ONE_AUTH_STRING</string></value> </param> </params> </methodCall>" $ONE_XMLRPC 1> $DEST_DIR/hostpool.xml

any ideas?
i tried with oneadmin to exclude some visibility issue, but the same result.

Maybe using the wrong credentials, by default users cannot access the host
pool list…


I’m so glad if that’s all. I’ll recheck which permissions I gave to the user!



yes it was an ACL mistake. I had already fixed it but incorrectly called the downloader that fetches the updated hostpoolinfo.

I’ll update here with the minimum ACL needed.

Thank you!

p.s.: oneinsight on small clusters? Forget it :slight_smile:
This will visualize best once you’re >500cores

what I used is this:

#2 HOST/* USE *

“USE” being the most minimal priv, and #2 is my oneinsight user’s ID.

This is what it looks like on a lab sys with just 8 cores.

This is what it looks like on a 96core system that is not full…

A tool for the big guys! :slight_smile: