VNC not working on instantiation

I’m still working my way through setting up a new vOneCloud 5.12 installation, and have one other question. We’re deploying to a vSphere 6 cluster with DRS enabled. When I deploy a VM, it’s get’s instantiated ok, but when you try to initiate a VNC connection, I get this message;

Could not determine the vCenter ESX host where the VM is running. Wait till the VCENTER_ESX_HOST attribute is retrieved once the host has been monitored

I wait, and wait, but for some reason, that attribute never appears against the VM. I tried adding it to the vCenter Information in the VM template, which probably isn’t what I was meant to do, but I had to try something (this doesn’t work anyway). Is there anything I need to do to get this attribute to populate? How soon is it meant to appear?

FYI, our Linux templates are specifically configured to pause during the first boot and drop into single user mode where they prompt for a hostname. After that’s entered the VM reboots and finishes it’s setup before becoming usable, and the user needs to be able to initiate VNC to enter the hostname. The VM doesn’t have an IP at that point, but in past versions of vOneCloud, VNC always worked initially - it was only when DRS moved the VM that it broke. I was hoping (expecting), that later versions fixed that.


Anyone? This is a fundamental issue here. I’ve provisioned a VM in 5.12, and the VCENTER_ESX_HOST value never seems to appear or populate, which means VNC just isn’t working at all. It doesn’t matter how long you wait, and you can’t manually add the field either (not that I want to do that). The vCenter host shows as MONITORED, and all the ESXi hosts show with a status ON. This is blocking me deploying 5.12 at the moment.