Installation of Opennebula

During Installation of Opennebula, I am facing the following issue:

server@one-server:~/opennebula-5.2.1$ sudo apt-get install -y g++ libxmlrpc-c3-dev scons libsqlite3-dev libmysqlclient-dev libxml2-dev libssl-dev liblog4cpp5-dev ruby ruby-dev sqlite3
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package libxmlrpc-c3-dev

I tried finding out the package, but it do not works, as a result, compilation fails in later stages and hence I am not able to launch the opennebula.
Please suggest.


I’ve no experience building OpenNebula on debian based distro, but following the Build Dependencies doc you should try installing libxmlrpc-c++8-dev instead.

Kind Regards,
Anton Todorov


Yes, I confirm that libxmlrpc-c3-dev package is unavailable in ubuntu packages.

please use “libxmlrpc-c++8-dev” rather than “libxmlrpc-c3-dev”

My article may helpful for you

I am stuck on adding new KVM node :frowning: , my ticket.


Sure. Thanks Atodorov.

Thanks… It worked. great…
I am able to run the Opennebula now.
I am new to opennebula, yet searching how to create vm’s and how to use it.
Well, I am not able to understand your ticket. Can you explain me more so as I too can try helping you in someway if I can.
Thanks once again.

Now oneflow is not working. I am getting the following error:

server@one-server:/usr/share/one$ sudo oneflow-template list Error connecting to server (Failed to open TCP connection to localhost:2474 (Connection refused - connect(2) for “localhost” port 2474)).
Server: localhost:2474

Please help.

Hi Simar,
according to OneFlow docs:

The OneFlow commands do not interact directly with the OpenNebula daemon, there is a server that takes the requests and manages the Service (multi-tiered application) life-cycle.

So you have to start OneFlow service first if you want to run oneflow-* commands. You can do it like this:

systemctl start opennebula-flow or service opennebula-flow start it will depend on what uses your Linux distro to manage services.

Once it’s started you can try those commands again and if you want to check if the server is running:

ss -ntap | grep 2474 should show something like this:

LISTEN 0 100 : users:((“ruby”,pid=1209,fd=10))


Hi simarpreetsingh

Thanks for your offer. When I add new KVM host via sunstone, the status always show error. Oned.log shows the error when master node login to KVM node (via ssh) and execute probe script. That probe script execution always return “Abort (core dump)”. I debug it but it seem the issue is in Ruby, not OpenNubela.

I use VMWare running two guest hosts, One Master node and KVM node. Both guest nodes are Ubunto 16.04, Ruby 2.3 and One 5.2.0.

Please don’t spend your time on my issue too much.

Hello Tor,

Can you share your contact details or whatsapp contact so as I can
contact you, if possible.

Thanks & Regards,
Simar Preet Singh

Hi Miguel,

Thanks for the concern.
I tried running the was you told, but its giving me the error as: no command ‘systemct1’ found.

Please Suggest.

Yesterday opennebula started working. then i closed the server. and now it is not working. I tried starting the sunstone server also, but it is giving the error.

Hi Simar!,
as the screenshot suggests, the command is systemctl ended with letter l not number 1.

In any case, I understand that you have installed OpenNebula from source didn’t you? maybe the package installation would be better for beginners so you have less things to worry about and start playing with OpenNebula right away. What Linux distribution are you using?

The problems you have in your last message are due to a permissions issue, your oneadmin user cannot create the /var/run/one directory or create the /var/lock/one/.sunstone.lock file…it would be better for you to add some services that starts opennebula, opennebula-sunstone and oneflow services for you. If you want to continue without services you can run the following commands as root:

  • mkdir /var/run/one;chown oneadmin:oneadmin /var/run/one
  • mkdir /var/lock/one;chown oneadmin:oneadmin /var/lock/one

And try to run the same commands again…


Thanks… It worked.
I am not able to run Opennebula Flow Services for scalability. When I try to start the server, it says the PATH of /usr/sbin needs to be added.

But this path already exists in the PATH. Still even after adding it again, I am not able to launch the services.

Please Suggest.

Hi Simar,
could you tell us what Linux distribution and version are you using? (Debian, Ubuntu?) with that information we may help you better.

As you’re launching your servers manually without using system services, you should launch the oneflow service using the: oneflow-server start command.

Again I’d recommend you to install OpenNebula using packages if you’re doing a test.


Hi simarpreetsingh,

Judging from the screenshot you are trying to start a service using the oneadmin user. On some Linux distributions you must be a privileged user (like root) to start a service.

Please try to start the service as root.

Kind Regards,
Anton Todorov


Please feel free to drop me a message via forum inbox :slight_smile:

Hi Friends,

While trying to make Host in Opennebula, I am getting the error. log File of the error is as follows:

Please Help.

Dear Friends,

I am not able to create an Image after the successful Host Creation. Can you please guide me with the correct syntax of it?